WordPress „Kein Zeilenumbruch“ Problem gelöst

Bei einigen WordPress Installationen ist ein seltsamer Fehler aufgetreten

der nach dem Speichern des Beitrages alle Zeilenumbrüche gelöscht hat.

Nach langer Suche hab ich endlich eine Möglichkeit gefunden das

WordPress Zeilenumbruch Problem zu lösen..

 

 

 

 

 

 

Und zwar mit dem fantastischen Plugin von „Andrew Ozz„:

„TinyMCE Advanced“ Editor.

Dieses Plugin ersetzt den Hauseigenen WordPress „WYSIWYG“ mit dem „Advanced“ Editor.

Dieser bietet erstens viel mehr Funktionen und zweitens, das wichtigste, er entfernt das

Zeilenumbruch Problem.

 

Das Plugin findet ihr hier : http://wordpress.org/extend/plugins/tinymce-advanced/

Einfach wie jedes andere Plugin installieren,

dann unter den „Einstellungen“ den „TinyMCE Advanced“ auswählen und bei

„Stop removing the <p> and <br /> tags when saving and show them in the HTML editor“

einen Haken setzen. Fertig 😎

 

 

Nun funktioniert wieder die „Enter“ Taste wie sie sollte.

Funktioniert es bei euch auch?

Bitte um Rückmeldung !

2009-03-24T11:00:08+00:00 24 März, 2009|Blog/News, Wordpress|26 Kommentare

26 Kommentare

  1. Julia Stern 28. März 2009 um 21:30 Uhr - Antworten

    Das Problem hatte ich auch lange Zeit, bis mir jemand (weiß gar nicht mehr wer das war) diesen Tipp gegeben hat. Seit dem funktioniert es auch bei mir. Darüber bin ich echt happy, denn dieses Zeilenumbruch- Problem hat mich immer total genervt.

    Liebe Grüße
    Julia

  2. Ja eh aber ... 18. Mai 2009 um 14:52 Uhr - Antworten

    Hallo! Der von dir empfohlenen Editor ist schon toll. Leider gibt es einen Fehler wenn man den Editor gemeinsam mit dem Plugin qTranslate nützt. Beim Speichern einer Seite wird automatisch oben ein Abstand eingefügt.

    Da es scheinbar keine Lösung für diese Problem gibt, bleibt mir also nichts weiter übrig als auf den tinyMCE zu verzichten.

    Hat jemand inen Tipp für mich?

    Danke & Grüße!

  3. Richard 23. Januar 2010 um 16:23 Uhr - Antworten

    Danke, genau soetwas habe ich gebraucht!

  4. Mona 26. Januar 2010 um 16:54 Uhr - Antworten

    Bei mir hat das Plugin leider nicht geholfen 🙁

    • wario 26. Januar 2010 um 17:21 Uhr - Antworten

      Seltsam.. bei vielen hat es funktioniert. Auch das häckchen gemacht ?

  5. VIC 22. März 2010 um 15:51 Uhr - Antworten

    Super, DANKE es hat auch bei mir geholfen, das hat mich immer gewaltig geärgert.

  6. ThirtyFive 3. April 2010 um 19:14 Uhr - Antworten

    Mir hat es schon was gebracht, aber erst nachdem ich die beiträge editiert habe

  7. ThirtyFive 3. April 2010 um 19:14 Uhr - Antworten

    Nein hat doch nicht geklappt -.-

  8. ThirtyFive 3. April 2010 um 19:20 Uhr - Antworten

    Ich habs gelöst … mein p-class war in der css datei als margin und padding 0 angegeben

  9. herb37 14. April 2010 um 11:30 Uhr - Antworten

    Leider klappt es bei mir nicht.
    Verwende die Thema „Mandigo“ und WP 2.9.1

    Haken ist gesetzt.
    Müsste nicht auch eim Editieren oder Anlegen der TinyEditor erscheinen, da sehe ich immer noch den WP-Editor.

    Hat bitte jemand einen weiteren Tipp.

    Vielen Dank im Voraus.

    Viele Grüße
    sendet
    Herbert

  10. Dennis Farin 20. Mai 2010 um 15:52 Uhr - Antworten

    Also irgendwie funktioniert das immer noch nicht bei mir.
    Seltsam finde ich eigentlich nur das es dem Editor egal ist ob ich nun HTML Code eingebe und verwende, oder ob ich den visuellen Editor nutze.
    Es wird einfach alles rausgecleared.

  11. Buzz 24. Januar 2011 um 10:52 Uhr - Antworten

    Super, vielen Dank! War echt ein nerviges Problem und eine simple Lösung.

  12. xy 13. Februar 2011 um 13:04 Uhr - Antworten

    Thx! War grade kurz vorm verzweifeln, bis ich Deinen Beitrag hier gefunden hatte. Nun funktionierts. Danke!!!

  13. Frank 7. März 2011 um 22:44 Uhr - Antworten

    Das Problem wäre eigentlich keines, denn der tinyMCE bietet das als Option an:
    http://tinymce.moxiecode.com/wiki.php/Configuration:remove_linebreaks

    Ich habe auch in einer WP-Installation eine tiny_mce_config.php in der in einem Array die Optionen für den Editor einstellbar sind, jedoch gibt es diese Datei in den anderen Installationen nicht.
    So wie ich das sehe, hat es WordPress willentlich oder versehentlich versäumt, die Options für die Entwickler einstellbar zu machen. Der Javascriptcode vom MCE in WordPress ist extrem komprimiert, da findet man sich nicht zurecht.

  14. Gerhard 23. Mai 2011 um 16:48 Uhr - Antworten

    *puh* Bin gerade ziemlich am Kämpfen mit diesem Plugin. Leider werden nach der Installation der Editor und auch kein Beitragstext mehr angezeigt. Keine Ahnung warum. Alle anderen Plugins habe ich schon deaktiviert – auch ohne Ergebnis. Nun habe ich die Vermutung, ob es vielleicht mit dem Theme zusammenhängen kann? Aber kann das sein?

  15. Spreadinator 8. Juni 2011 um 10:31 Uhr - Antworten

    Klappt tadellos. Noch wichtiger als das Häkchen zu setzen, ist das Häkchen bei Context Menü (siehe Screenshot oben) wegzulassen!

  16. Gerhard 15. Juni 2011 um 11:19 Uhr - Antworten

    @Spreadinator: Danke für den Hinweis. Ich hab das Plugin nun mal mit einem anderen Theme probiert – da funktioniert alles einwandfrei. Dürfe sich also tatsächlich nicht vertragen… Schade. 🙁

  17. pix123 31. August 2011 um 16:26 Uhr - Antworten

    Sehr wertvoller Tipp. Was wäre WordPress ohne solch hilfreichen Plugins?!
    Besten Dank.

  18. Andi K. 12. Januar 2012 um 23:16 Uhr - Antworten

    Danke für den Tipp! War schon am verzweifeln 😉

    Habe dich auch direkt mal verlinkt 😀

  19. Celine Bocquillon 24. Februar 2012 um 12:01 Uhr - Antworten

    Danke, es hat bei mir funktioniert!

  20. Ingo 3. April 2012 um 19:34 Uhr - Antworten

    Danke ! Was hat mich dieser Bug genervt, ich hatte sogar begonnen die ´s im Code hinzuzufügen aber immer wieder wurden sie gelöscht. Auf die Idee die Settings anzusehen kam ich natürlich nicht 😉

  21. Meister Web 17. September 2012 um 2:03 Uhr - Antworten

    Vielen Dank für diesen Artikel!

    Gruesse

Hinterlassen Sie einen Kommentar

Erfahrungen & Bewertungen zu Digital-Workshop.at